GitHub Advisoryadvisory · Maven
GHSA-f8r7-7hv9-7f43 Jenkins CAS Plugin Server-Side Request Forgery vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1000188
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:cas-plugin
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-918
- Reviewed
- 2022-12-12
Affected packages
• Maven org.jenkins-ci.plugins:cas-plugin: < 1.4.2 → fixed in 1.4.2
Description
A server-side request forgery vulnerability exists in Jenkins CAS Plugin 1.4.1 and older in CasSecurityRealm.java that allows attackers with Overall/Read access to cause Jenkins to send a GET request to a specified URL. Additionally, this form validation method did not require POST requests, resulting in a CSRF vulnerability. As of version 1.4.2, this form validation method requires POST requests and the Overall/Administer permission.
Related
Alias · CVE (1)
- CVE-2018-1000188 A server-side request forgery vulnerability exists in Jenkins CAS Plugin 1.4.1 and older in CasSecurityRealm.java that allows attackers… vulnerability
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness