GitHub Advisoryadvisory · PyPI
GHSA-f8vc-f28w-x9c9 Apache Superset Cross-site Scripting (XSS) vulnerability on the Explore page
MEDIUM
Official page ↗
- Aliases
- CVE-2021-32609
- Ecosystem
- PyPI
- Packages
- apache-superset
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-06-21
Affected packages
• PyPI apache-superset: < 1.2.0 → fixed in 1.2.0
Description
Apache Superset up to and including 1.1 does not sanitize titles correctly on the Explore page. This allows an attacker with Explore access to save a chart with a malicious title, injecting html (including scripts) into the page.
Related
Alias · CVE (1)
- CVE-2021-32609 Apache Superset up to and including 1.1 does not sanitize titles correctly on the Explore page. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-32609 advisory
- https://github.com/advisories/GHSA-f8vc-f28w-x9c9 advisory
- https://github.com/apache/superset web
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-superset/PYSEC-2021-377.yaml web
- https://lists.apache.org/thread.html/r2c09254e98b4f8b3deb422762bd0e2aa6d743b72d96c2f90cbaae31a%40%3Cdev.superset.apache.org%3E web