GitHub Advisoryadvisory · RubyGems

GHSA-f93j-hmcr-jcwh Moped Rubygem Data Injection Vulnerability

HIGH Published 2020-08-19 Modified 2023-08-25 Official page ↗
Aliases
CVE-2015-4410
Ecosystem
RubyGems
Packages
moped
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20
Reviewed
2020-08-14

Affected packages

• RubyGems moped: < 1.5.3 → fixed in 1.5.3 • RubyGems moped: >= 2.0.0, < 2.0.5 → fixed in 2.0.5

Description

`The Moped::BSON::ObjecId.legal?` method in rubygem-moped before commit dd5a7c14b5d2e466f7875d079af71ad19774609b allows remote attackers to cause a denial of service (worker resource consumption) or perform a cross-site scripting (XSS) attack via a crafted string.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References