GitHub Advisoryadvisory · Maven
GHSA-f9cx-789c-w2mr Incorrect Authorization in Jenkins Mercurial Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1000112
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:mercurial
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2022-06-30
Affected packages
• Maven org.jenkins-ci.plugins:mercurial: < 2.3 → fixed in 2.3
Description
An improper authorization vulnerability exists in Jenkins Mercurial Plugin version 2.2 and earlier in MercurialStatus.java that allows an attacker with network access to obtain a list of nodes and users.
Related
Alias · CVE (1)
- CVE-2018-1000112 An improper authorization vulnerability exists in Jenkins Mercurial Plugin version 2.2 and earlier in MercurialStatus.java that allows an… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness