GitHub Advisoryadvisory · Maven
GHSA-f9gf-2q87-5m44 Stored XSS vulnerability in Jenkins Scriptler Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2021-21700
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:scriptler
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-12-15
Affected packages
• Maven org.jenkins-ci.plugins:scriptler: < 3.4 → fixed in 3.4
Description
Jenkins Scriptler Plugin 3.3 and earlier does not escape the name of scripts on the UI when asking to confirm their deletion.
This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to create Scriptler scripts.
Jenkins Scriptler Plugin 3.4 escapes the name of scripts on the UI when asking to confirm their deletion.
Related
Alias · CVE (1)
- CVE-2021-21700 Jenkins Scriptler Plugin 3.3 and earlier does not escape the name of scripts on the UI when asking to confirm their deletion, resulting in… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-21700 advisory
- https://github.com/jenkinsci/scriptler-plugin/commit/7e4fa9b51f37714decca30a35dd81e41f72aec93 web
- https://github.com/jenkinsci/scriptler-plugin package
- https://www.jenkins.io/security/advisory/2021-11-12/#SECURITY-2406 web
- http://www.openwall.com/lists/oss-security/2021/11/12/1 web