GitHub Advisoryadvisory · Packagist

GHSA-f9m9-494r-w36p Moodle allows bypass of intended access restrictions

MEDIUM Published 2022-05-13 Modified 2024-01-23 Official page ↗
Aliases
CVE-2014-0122
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Reviewed
2024-01-23

Affected packages

• Packagist moodle/moodle: < 2.4.9 → fixed in 2.4.9 • Packagist moodle/moodle: >= 2.5.0, < 2.5.5 → fixed in 2.5.5 • Packagist moodle/moodle: >= 2.6.0, < 2.6.2 → fixed in 2.6.2

Description

mod/chat/chat_ajax.php in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 does not properly check for the mod/chat:chat capability during chat sessions, which allows remote authenticated users to bypass intended access restrictions in opportunistic circumstances by remaining in a chat session after an intra-session capability removal by an administrator.

Related

Alias · CVE (1)

  • CVE-2014-0122 mod/chat/chat_ajax.php in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 does not properly check for… vulnerability

References