GitHub Advisoryadvisory · PyPI

GHSA-fc4h-467w-46rh Ansible Arbitrary Code Execution

HIGH Published 2022-05-13 Modified 2024-09-05 Official page ↗
Aliases
CVE-2018-10875
Ecosystem
PyPI
Packages
ansible
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-426
Reviewed
2024-04-22

Affected packages

• PyPI ansible: < 2.4.6.0 → fixed in 2.4.6.0 • PyPI ansible: >= 2.5.0a1, < 2.5.6 → fixed in 2.5.6 • PyPI ansible: >= 2.6.0a1, < 2.6.1 → fixed in 2.6.1

Description

A flaw was found in ansible. ansible.cfg is read from the current working directory which can be altered to make it point to a plugin or a module path under the control of an attacker, thus allowing the attacker to execute arbitrary code.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-426 Untrusted Search Path weakness

References