GitHub Advisoryadvisory · Packagist

GHSA-fc5p-vj3h-x7g4 Moodle allows attackers to obtain sensitive information

MEDIUM Published 2022-05-13 Modified 2024-01-24 Official page ↗
Aliases
CVE-2014-0124
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Reviewed
2024-01-24

Affected packages

• Packagist moodle/moodle: < 2.4.9 → fixed in 2.4.9 • Packagist moodle/moodle: >= 2.5.0, < 2.5.5 → fixed in 2.5.5 • Packagist moodle/moodle: >= 2.6.0, < 2.6.2 → fixed in 2.6.2

Description

The identity-reporting implementations in mod/forum/renderer.php and mod/quiz/override_form.php in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 do not properly restrict the display of e-mail addresses, which allows remote authenticated users to obtain sensitive information by using the (1) Forum or (2) Quiz module.

Related

Alias · CVE (1)

  • CVE-2014-0124 The identity-reporting implementations in mod/forum/renderer.php and mod/quiz/override_form.php in Moodle through 2.3.11, 2.4.x before… vulnerability

References