GitHub Advisoryadvisory · Maven

GHSA-fccv-jmmp-qg76 Apache Tomcat Improper Input Validation vulnerability

HIGH Published 2023-11-28 Modified 2026-10-02 Official page ↗
Aliases
CVE-2023-46589
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat-coyote
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-20, CWE-444
Reviewed
2023-11-28

Affected packages

• Maven org.apache.tomcat:tomcat-catalina: >= 11.0.0-M1, < 11.0.0-M11 → fixed in 11.0.0-M11 • Maven org.apache.tomcat:tomcat-catalina: >= 10.1.0-M1, < 10.1.16 → fixed in 10.1.16 • Maven org.apache.tomcat:tomcat-catalina: >= 9.0.0-M1, < 9.0.83 → fixed in 9.0.83 • Maven org.apache.tomcat:tomcat-catalina: >= 8.5.0, < 8.5.96 → fixed in 8.5.96 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.0-M1, < 11.0.0-M11 → fixed in 11.0.0-M11 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.0-M1, < 10.1.16 → fixed in 10.1.16 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.0-M1, < 9.0.83 → fixed in 9.0.83 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 8.5.0, < 8.5.96 → fixed in 8.5.96 • Maven org.apache.tomcat:tomcat-coyote: >= 11.0.0-M1, < 11.0.0-M11 → fixed in 11.0.0-M11

Description

Improper Input Validation vulnerability in Apache Tomcat. Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82, and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.

Related

Alias · CVE (1)

  • CVE-2023-46589 Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from… vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-444 Inconsistent Interpretation of HTTP Requests weakness

References