GitHub Advisoryadvisory · Packagist
GHSA-fcmw-wx57-9p75 Mautic has SQL Injection in API Contact Filtering
HIGH
Official page ↗
- Aliases
- CVE-2026-4776
- Ecosystem
- Packagist
- Packages
- mautic/core
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:L
- Weaknesses
- CWE-89
- Reviewed
- 2026-07-02
Affected packages
• Packagist mautic/core: >= 2.6.0, <= 4.4.13 (no fix yet)
• Packagist mautic/core: >= 5.0.0, < 5.2.11 → fixed in 5.2.11
• Packagist mautic/core: >= 6.0.0, < 6.0.9 → fixed in 6.0.9
• Packagist mautic/core: >= 7.0.0, < 7.1.2 → fixed in 7.1.2
Description
Summary
An SQL injection vulnerability exists in Mautic's API contact filtering mechanism. Due to insufficient recursive sanitization of nested query parameters, an authenticated API user can bypass input filtering and inject arbitrary SQL commands.
Impact
An authenticated user with API access can exploit this vulnerability to execute arbitrary SQL queries against the underlying database. This allows unauthorized retrieval of sensitive database contents—including user credentials, system configurations, and personal identifiable information (PII) of contacts—bypassing standard data access permissions.
Patched Versions
This security issue has been fixed in the following releases:
• 7.1.2
• 6.0.9
• 5.2.11
• 4.4.20 ELTS
We strongly recommend upgrading to the latest version corresponding to your release branch.
Workarounds
There are no official workarounds. To mitigate this issue without upgrading, you may temporarily disable API access or restrict API permissions to highly trusted accounts.
Related
Alias · CVE (1)
- CVE-2026-4776 An SQL injection vulnerability exists in Mautic's API contact filtering mechanism. vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness