GitHub Advisoryadvisory · Maven
GHSA-fcr6-6cph-vmcm Stored XSS vulnerability in Jenkins Git Parameter Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2022-29040
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.tools:git-parameter
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-04-29
Affected packages
• Maven org.jenkins-ci.tools:git-parameter: < 0.9.16 → fixed in 0.9.16
Description
Jenkins Git Parameter Plugin 0.9.15 and earlier does not escape the name and description of Git parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Related
Alias · CVE (1)
- CVE-2022-29040 Jenkins Git Parameter Plugin 0.9.15 and earlier does not escape the name and description of Git parameters on views displaying parameters,… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness