GitHub Advisoryadvisory · Packagist

GHSA-fcww-8wvc-38q9 phpMyAdmin SQL injection vulnerability

MEDIUM Published 2022-05-24 Modified 2024-04-24 Official page ↗
Aliases
CVE-2020-10803
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79, CWE-89
Reviewed
2024-04-24

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 3.4, < 4.9.5 → fixed in 4.9.5 • Packagist phpmyadmin/phpmyadmin: >= 5.0.0, < 5.0.2 → fixed in 5.0.2

Description

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was discovered where malicious code could be used to trigger an XSS attack through retrieving and displaying results (in tbl_get_field.php and libraries/classes/Display/Results.php). The attacker must be able to insert crafted data into certain database tables, which when retrieved (for instance, through the Browse tab) can trigger the XSS attack.

Related

Alias · CVE (1)

  • CVE-2020-10803 In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was discovered where malicious code could be used to… vulnerability

Weakness · CWE (2)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness
  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References