GitHub Advisoryadvisory · PyPI
GHSA-fffj-9qwg-qmh5 Improper Input Validation in OpenCV
MEDIUM
Official page ↗
- Aliases
- CVE-2016-1517
- Ecosystem
- PyPI
- Packages
- opencv-python, opencv-contrib-python
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2021-10-08
Affected packages
• PyPI opencv-python: < 3.3.1.11 → fixed in 3.3.1.11
• PyPI opencv-contrib-python: < 3.3.1.11 → fixed in 3.3.1.11
Description
OpenCV 3.0.0 allows remote attackers to cause a denial of service (segfault) via vectors involving corrupt chunks. This issue was fixed in OpenCV version 3.3.1 (corresponding to OpenCV 3.3.1.11).
Related
Alias · CVE (1)
- CVE-2016-1517 OpenCV 3.0.0 allows remote attackers to cause a denial of service (segfault) via vectors involving corrupt chunks. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness