GitHub Advisoryadvisory · Maven
GHSA-ffgg-vphh-v273 Incomplete List of Disallowed Inputs in Jenkins
MEDIUM
Official page ↗
- Aliases
- CVE-2017-2602
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-184
- Reviewed
- 2022-07-01
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: < 2.32.2 → fixed in 2.32.2
• Maven org.jenkins-ci.main:jenkins-core: >= 2.34, < 2.44 → fixed in 2.44
Description
Jenkins before versions 2.44 and 2.32.2 is vulnerable to an improper blacklisting of the Pipeline metadata files in the agent-to-master security subsystem. This could allow metadata files to be written to by malicious agents (SECURITY-358).
Related
Alias · CVE (1)
- CVE-2017-2602 jenkins before versions 2.44, 2.32.2 is vulnerable to an improper blacklisting of the Pipeline metadata files in the agent-to-master… vulnerability
Weakness · CWE (1)
- CWE-184 Incomplete List of Disallowed Inputs weakness