GitHub Advisoryadvisory · npm
GHSA-ffhc-5mcf-pf4q Next.js vulnerable to cross-site scripting in App Router applications using CSP nonces
MEDIUM
Official page ↗
- Aliases
- CVE-2026-44581
- Ecosystem
- npm
- Packages
- next
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2026-05-11
Affected packages
• npm next: >= 13.4.0, < 15.5.16 → fixed in 15.5.16
• npm next: >= 16.0.0, < 16.2.5 → fixed in 16.2.5
Description
Impact
App Router applications that rely on CSP nonces can be vulnerable to stored cross-site scripting when deployed behind shared caches. In affected versions, malformed nonce values derived from request headers could be reflected into rendered HTML in an unsafe way, allowing an attacker to poison cached responses and cause script execution for later visitors.
Fix
We now reject or ignore malformed nonce values before they are embedded into HTML and apply stricter nonce sanitization so request-derived nonce data cannot break out of the intended attribute context.
Workarounds
If you cannot upgrade immediately, strip inbound `Content-Security-Policy` request headers from untrusted traffic.
Related
Alias · CVE (1)
- CVE-2026-44581 Next.js is a React framework for building full-stack web applications. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness