GitHub Advisoryadvisory · PyPI

GHSA-ffjm-4qwc-7cmf TensorFlow vulnerable to OOB write in `scatter_nd` in TF Lite

HIGH Published 2022-09-16 Modified 2022-09-19 Official page ↗
Aliases
CVE-2022-35939
Ecosystem
PyPI
Packages
tensorflow, tensorflow-cpu, tensorflow-gpu
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
Weaknesses
CWE-787
Reviewed
2022-09-16

Affected packages

• PyPI tensorflow: < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • PyPI tensorflow: >= 2.9.0, < 2.9.1 → fixed in 2.9.1 • PyPI tensorflow-cpu: < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow-cpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • PyPI tensorflow-cpu: >= 2.9.0, < 2.9.1 → fixed in 2.9.1 • PyPI tensorflow-gpu: < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow-gpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • PyPI tensorflow-gpu: >= 2.9.0, < 2.9.1 → fixed in 2.9.1

Description

Impact The `ScatterNd` function takes an input argument that determines the indices of of the output tensor. An input index greater than the output tensor or less than zero will either write content at the wrong index or trigger a crash. Patches We have patched the issue in GitHub commit b4d4b4cb019bd7240a52daa4ba61e3cc814f0384. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability has been reported by Hui Peng from Baidu Security.

Related

Alias · CVE (1)

  • CVE-2022-35939 TensorFlow is an open source platform for machine learning. vulnerability

Weakness · CWE (1)

  • CWE-787 Out-of-bounds Write weakness

References