GitHub Advisoryadvisory · PyPI

GHSA-ffq8-576r-v26g HPACK Denial of Service vulnerability (HPACK Bomb)

HIGH Published 2019-07-05 Modified 2024-09-20 Official page ↗
Aliases
CVE-2016-6581
Ecosystem
PyPI
Packages
hpack
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Reviewed
2020-06-16

Affected packages

• PyPI hpack: >= 1.0.0, < 2.3.0 → fixed in 2.3.0

Description

A HTTP/2 implementation built using any version of the Python HPACK library between v1.0.0 and v2.2.0 could be targeted for a denial of service attack, specifically a so-called "HPACK Bomb" attack. This attack occurs when an attacker inserts a header field that is exactly the size of the HPACK dynamic header table into the dynamic header table. The attacker can then send a header block that is simply repeated requests to expand that field in the dynamic table. This can lead to a gigantic compression ratio of 4,096 or better, meaning that 16kB of data can decompress to 64MB of data on the target machine.

Related

Alias · CVE (1)

  • CVE-2016-6581 A HTTP/2 implementation built using any version of the Python HPACK library between v1.0.0 and v2.2.0 could be targeted for a denial of… vulnerability

References