GitHub Advisoryadvisory · Maven

GHSA-ffvq-7w96-97p7 Denial of Service in Spring Framework

HIGH Published 2020-06-15 Modified 2024-06-05 Official page ↗
Aliases
CVE-2018-15756
Ecosystem
Maven
Packages
org.springframework:spring-core
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Reviewed
2020-06-11

Affected packages

• Maven org.springframework:spring-core: >= 5.1.0.RELEASE, < 5.1.1.RELEASE → fixed in 5.1.1.RELEASE • Maven org.springframework:spring-core: >= 5.0.0.RELEASE, < 5.0.10.RELEASE → fixed in 5.0.10.RELEASE • Maven org.springframework:spring-core: >= 4.2.0.RELEASE, < 4.3.20.RELEASE → fixed in 4.3.20.RELEASE

Description

Spring Framework, version 5.1, versions 5.0.x prior to 5.0.10, versions 4.3.x prior to 4.3.20, and older unsupported versions on the 4.2.x branch provide support for range requests when serving static resources through the ResourceHttpRequestHandler, or starting in 5.0 when an annotated controller returns an org.springframework.core.io.Resource. A malicious user (or attacker) can add a range header with a high number of ranges, or with wide ranges that overlap, or both, for a denial of service attack. This vulnerability affects applications that depend on either spring-webmvc or spring-webflux. Such applications must also have a registration for serving static resources (e.g. JS, CSS, images, and others), or have an annotated controller that returns an org.springframework.core.io.Resource. Spring Boot applications that depend on spring-boot-starter-web or spring-boot-starter-webflux are ready to serve static resources out of the box and are therefore vulnerable.

Related

Alias · CVE (1)

  • CVE-2018-15756 Spring Framework, version 5.1, versions 5.0.x prior to 5.0.10, versions 4.3.x prior to 4.3.20, and older unsupported versions on the 4.2.x… vulnerability

References