GitHub Advisoryadvisory · PyPI

GHSA-ffw3-6mp6-jmvj Improper Access Control in Apache Airflow

HIGH Published 2021-04-07 Modified 2024-11-18 Official page ↗
Aliases
CVE-2021-26559
Ecosystem
PyPI
Packages
apache-airflow
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-269, CWE-284
Reviewed
2021-04-01

Affected packages

• PyPI apache-airflow: >= 2.0.0, < 2.0.1rc1 → fixed in 2.0.1rc1

Description

Improper Access Control on Configurations Endpoint for the Stable API of Apache Airflow allows users with Viewer or User role to get Airflow Configurations including sensitive information even when `[webserver] expose_config` is set to `False` in `airflow.cfg`. This allowed a privilege escalation attack. This issue affects Apache Airflow 2.0.0.

Related

Alias · CVE (1)

  • CVE-2021-26559 Improper Access Control on Configurations Endpoint for the Stable API of Apache Airflow allows users with Viewer or User role to get… vulnerability

Weakness · CWE (2)

  • CWE-269 Improper Privilege Management weakness
  • CWE-284 Improper Access Control weakness

References