GitHub Advisoryadvisory · Go
GHSA-fg25-gq9g-32mx Cross site scripting in Cloudreve
MEDIUM
Official page ↗
- Aliases
- CVE-2022-32167
- Ecosystem
- Go
- Packages
- github.com/HFO4/cloudreve, github.com/cloudreve/Cloudreve/v3
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-09-23
Affected packages
• Go github.com/HFO4/cloudreve: >= 1.0.0, <= 2.0.0 (no fix yet)
• Go github.com/cloudreve/Cloudreve/v3: >= 3.0.0, < 3.6.0-beta1 → fixed in 3.6.0-beta1
Description
Cloudreve versions v1.0.0 through v3.5.3 are vulnerable to Stored Cross-Site Scripting (XSS), via the file upload functionality. A low privileged user will be able to share a file with an admin user, which could lead to privilege escalation.
Related
Alias · CVE (1)
- CVE-2022-32167 Cloudreve versions v1.0.0 through v3.5.3 are vulnerable to Stored Cross-Site Scripting (XSS), via the file upload functionality. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-32167 advisory
- https://github.com/cloudreve/Cloudreve/commit/4b85541d73949969f41ad46d1e00544c9f1a7538 web
- https://github.com/cloudreve/Cloudreve package
- https://github.com/cloudreve/Cloudreve/releases/tag/3.6.0-beta1 web
- https://www.mend.io/vulnerability-database/CVE-2022-32167 web