GitHub Advisoryadvisory · Go
GHSA-fg35-5rf6-qg3g Mattermost allows attackers to take over arbitrary user accounts via overly permissive substring matching flaw
MEDIUM
Official page ↗
- Aliases
- CVE-2026-27656
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server, github.com/mattermost/mattermost/server/v8
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-303
- Reviewed
- 2026-03-31
Affected packages
• Go github.com/mattermost/mattermost-server: >= 11.4.0-rc1, < 11.4.1 → fixed in 11.4.1
• Go github.com/mattermost/mattermost-server: >= 11.3.0-rc1, < 11.3.2 → fixed in 11.3.2
• Go github.com/mattermost/mattermost-server: >= 11.2.0-rc1, < 11.2.4 → fixed in 11.2.4
• Go github.com/mattermost/mattermost-server: >= 10.11.0-rc1, < 10.11.12 → fixed in 10.11.12
• Go github.com/mattermost/mattermost/server/v8: >= 8.0.0-20260105080200-d27a2195068d, < 8.0.0-20260217110922-b7d4a1f1f59b → fixed in 8.0.0-20260217110922-b7d4a1f1f59b
Description
Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to properly validate user identity in the OpenID {{IsSameUser()}} comparison logic, which allows an attacker to take over arbitrary user accounts via an overly permissive substring matching flaw in the user discovery flow. Mattermost Advisory ID: MMSA-2026-00590
Related
Alias · CVE (1)
- CVE-2026-27656 Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to properly validate user identity in… vulnerability
Weakness · CWE (1)
- CWE-303 Incorrect Implementation of Authentication Algorithm weakness