GitHub Advisoryadvisory · Packagist
GHSA-fgj8-93xx-f6g6 phpMyAdmin SQL injection in user accounts page
HIGH
Official page ↗
- Aliases
- CVE-2020-5504
- Ecosystem
- Packagist
- Packages
- phpmyadmin/phpmyadmin
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-89
- Reviewed
- 2024-04-24
Affected packages
• Packagist phpmyadmin/phpmyadmin: >= 4.0.0, < 4.9.4 → fixed in 4.9.4
• Packagist phpmyadmin/phpmyadmin: >= 5.0.0, < 5.0.1 → fixed in 5.0.1
Description
In phpMyAdmin 4 before 4.9.4 and 5 before 5.0.1, SQL injection exists in the user accounts page. A malicious user could inject custom SQL in place of their own username when creating queries to this page. An attacker must have a valid MySQL account to access the server.
Related
Alias · CVE (1)
- CVE-2020-5504 In phpMyAdmin 4 before 4.9.4 and 5 before 5.0.1, SQL injection exists in the user accounts page. vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-5504 advisory
- https://cybersecurityworks.com/zerodays/cve-2020-5504-phpmyadmin.html web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/phpmyadmin/phpmyadmin/CVE-2020-5504.yaml web
- https://github.com/MarkLee131/awesome-web-pocs/blob/main/CVE-2020-5504.md web
- https://github.com/phpmyadmin/composer package
- https://lists.debian.org/debian-lts-announce/2020/01/msg00011.html web
- https://www.phpmyadmin.net/security/PMASA-2020-1 web
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00024.html web