GitHub Advisoryadvisory · Maven
GHSA-fgxc-mxvw-55mv Jenkins Git Parameter Plugin vulnerable to stored cross-site scripting (XSS)
MEDIUM
Official page ↗
- Aliases
- CVE-2020-2113
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.tools:git-parameter
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-01-06
Affected packages
• Maven org.jenkins-ci.tools:git-parameter: < 0.9.12 → fixed in 0.9.12
Description
Jenkins Git Parameter Plugin 0.9.11 and earlier does not escape the default value shown on the UI, resulting in a stored cross-site scripting vulnerability exploitable by users with Job/Configure permission.
Related
Alias · CVE (1)
- CVE-2020-2113 Jenkins Git Parameter Plugin 0.9.11 and earlier does not escape the default value shown on the UI, resulting in a stored cross-site… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2113 advisory
- https://github.com/jenkinsci/git-parameter-plugin/commit/6fd933c5b1af4ec5dc27edfe2c74931dbff69012 web
- https://github.com/jenkinsci/git-parameter-plugin package
- https://jenkins.io/security/advisory/2020-02-12/#SECURITY-1709 web
- http://www.openwall.com/lists/oss-security/2020/02/12/3 web