GitHub Advisoryadvisory · PyPI

GHSA-fh2c-86xm-pm2x LiteLLM Vulnerable to Denial of Service (DoS) via Crafted HTTP Request

HIGH Published 2025-03-20 Modified 2025-10-15 Official page ↗
Aliases
CVE-2024-8984
Ecosystem
PyPI
Packages
litellm
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400, CWE-770
Reviewed
2025-03-20

Affected packages

• PyPI litellm: < 1.56.2 → fixed in 1.56.2

Description

A Denial of Service (DoS) vulnerability exists in berriai/litellm version v1.44.5. This vulnerability can be exploited by appending characters, such as dashes (-), to the end of a multipart boundary in an HTTP request. The server continuously processes each character, leading to excessive resource consumption and rendering the service unavailable. The issue is unauthenticated and does not require any user interaction, impacting all users of the service.

Related

Alias · CVE (1)

  • CVE-2024-8984 A Denial of Service (DoS) vulnerability exists in berriai/litellm version v1.44.5. vulnerability

Weakness · CWE (2)

  • CWE-400 Uncontrolled Resource Consumption weakness
  • CWE-770 Allocation of Resources Without Limits or Throttling weakness

References