GitHub Advisoryadvisory · RubyGems
GHSA-fh39-v733-mxfr Active Record vulnerable to SQL Injection via nested query parameters
MEDIUM
Official page ↗
- Aliases
- CVE-2012-2661
- Ecosystem
- RubyGems
- Packages
- activerecord
- Severity
- Moderate
- Weaknesses
- CWE-89
- Reviewed
- 2020-06-16
Affected packages
• RubyGems activerecord: >= 3.0.0, < 3.0.13 → fixed in 3.0.13
• RubyGems activerecord: >= 3.1.0, < 3.1.5 → fixed in 3.1.5
• RubyGems activerecord: >= 3.2.0, < 3.2.4 → fixed in 3.2.4
Description
The Active Record component in Ruby on Rails 3.0.x before 3.0.13, 3.1.x before 3.1.5, and 3.2.x before 3.2.4 does not properly implement the passing of request data to a where method in an ActiveRecord class, which allows remote attackers to conduct certain SQL injection attacks via nested query parameters that leverage unintended recursion, a related issue to CVE-2012-2695.
Related
Alias · CVE (1)
- CVE-2012-2661 The Active Record component in Ruby on Rails 3.0.x before 3.0.13, 3.1.x before 3.1.5, and 3.2.x before 3.2.4 does not properly implement… vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2012-2661 advisory
- https://groups.google.com/group/rubyonrails-security/msg/fc2da6c627fc92df?dmode=source&output=gplain web
- http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00014.html web
- http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00016.html web
- http://lists.opensuse.org/opensuse-updates/2012-08/msg00046.html web
- http://rhn.redhat.com/errata/RHSA-2013-0154.html web