GitHub Advisoryadvisory · Maven

GHSA-fh5w-p2j4-4p8x Exposure of Sensitive Information to an Unauthorized Actor in Jenkins Kubernetes Plugin

MEDIUM Published 2022-05-24 Modified 2023-05-24 Official page ↗
Aliases
CVE-2020-2307
Ecosystem
Maven
Packages
org.csanchez.jenkins.plugins:kubernetes
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-200
Reviewed
2022-06-23

Affected packages

• Maven org.csanchez.jenkins.plugins:kubernetes: >= 1.27.0, < 1.27.4 → fixed in 1.27.4 • Maven org.csanchez.jenkins.plugins:kubernetes: >= 1.26.0, < 1.26.5 → fixed in 1.26.5 • Maven org.csanchez.jenkins.plugins:kubernetes: >= 1.22.0, < 1.25.4.1 → fixed in 1.25.4.1 • Maven org.csanchez.jenkins.plugins:kubernetes: < 1.21.6 → fixed in 1.21.6

Description

Jenkins Kubernetes Plugin prior to 1.27.4, 1.26.5, 1.25.4.1, and 1.21.6 includes a feature to replace placeholders in pod template and container template fields with environment variable values. This feature allows low-privilege users to access possibly sensitive Jenkins controller environment variables. Kubernetes Plugin 1.27.4, 1.26.5, 1.25.4.1, and 1.21.6 disables this feature.

Related

Alias · CVE (1)

  • CVE-2020-2307 Jenkins Kubernetes Plugin 1.27.3 and earlier allows low-privilege users to access possibly sensitive Jenkins controller environment… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References