GitHub Advisoryadvisory · npm

GHSA-fhg7-m89q-25r3 ReDoS Vulnerability in ua-parser-js version

HIGH Published 2023-01-24 Modified 2025-10-17 Official page ↗
Aliases
CVE-2022-25927
Ecosystem
npm
Packages
ua-parser-js
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-1333, CWE-400
Reviewed
2023-01-24

Affected packages

• npm ua-parser-js: >= 0.7.30, < 0.7.33 → fixed in 0.7.33 • npm ua-parser-js: >= 0.8.0, < 1.0.33 → fixed in 1.0.33

Description

Description: A regular expression denial of service (ReDoS) vulnerability has been discovered in `ua-parser-js`. Impact: This vulnerability bypass the library's `MAX_LENGTH` input limit prevention. By crafting a very-very-long user-agent string with specific pattern, an attacker can turn the script to get stuck processing for a very long time which results in a denial of service (DoS) condition. Affected Versions: From version `0.7.30` to before versions `0.7.33` / `1.0.33`. Patches: A patch has been released to remove the vulnerable regular expression, update to version `0.7.33` / `1.0.33` or later. References: Regular expression Denial of Service - ReDoS Credits: Thanks to @Snyk who first reported the issue.

Related

Alias · CVE (1)

  • CVE-2022-25927 Versions of the package ua-parser-js from 0.7.30 and before 0.7.33, from 0.8.1 and before 1.0.33 are vulnerable to Regular Expression… vulnerability

Weakness · CWE (2)

  • CWE-1333 Inefficient Regular Expression Complexity weakness
  • CWE-400 Uncontrolled Resource Consumption weakness

References