GitHub Advisoryadvisory · PyPI

GHSA-fhhq-h4hg-549x ModelScope is vulnerable to arbitrary code injection via a crafted module

HIGH Published 2026-05-19 Modified 2026-06-04 Official page ↗
Aliases
CVE-2025-51427
Ecosystem
PyPI
Packages
modelscope
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-94
Reviewed
2026-06-04

Affected packages

• PyPI modelscope: < 1.27.0 → fixed in 1.27.0

Description

An issue was discovered in ModelScope 1.25.0 allowing attackers to execute arbitrary code via crafted module listed in the configuration file (dey_mini.yaml) under the key ['nnet']['module'].

Related

Alias · CVE (1)

  • CVE-2025-51427 An issue was discovered in ModelScope 1.25.0 allowing attackers to execute arbitrary code via crafted module listed in the configuration… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References