GitHub Advisoryadvisory · Packagist
GHSA-fj28-869x-vv5g SimpleSAMLphp InfoCard module Incorrect signature verification
HIGH
Official page ↗
- Aliases
- CVE-2017-12874
- Ecosystem
- Packagist
- Packages
- simplesamlphp/simplesamlphp-module-infocard
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2024-04-25
Affected packages
• Packagist simplesamlphp/simplesamlphp-module-infocard: < 1.0.1 → fixed in 1.0.1
Description
The InfoCard module 1.0 for SimpleSAMLphp allows attackers to spoof XML messages by leveraging an incorrect check of return values in signature validation utilities.
Related
Alias · CVE (1)
- CVE-2017-12874 The InfoCard module 1.0 for SimpleSAMLphp allows attackers to spoof XML messages by leveraging an incorrect check of return values in… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-12874 advisory
- https://github.com/simplesamlphp/simplesamlphp-module-infocard/commit/63b84cc837ea62bf87f4bf4af29b4420f49311a9 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/simplesamlphp/simplesamlphp-module-infocard/CVE-2017-12874.yaml web
- https://github.com/simplesamlphp/simplesamlphp package
- https://lists.debian.org/debian-lts-announce/2017/12/msg00007.html web
- https://simplesamlphp.org/security/201612-03 web
- https://www.debian.org/security/2018/dsa-4127 web