GitHub Advisoryadvisory · PyPI
GHSA-fj32-q626-pjjc LangChain vulnerable to arbitrary code execution
CRITICAL
Official page ↗
- Aliases
- CVE-2023-38860
- Ecosystem
- PyPI
- Packages
- langchain
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2023-08-15
Affected packages
• PyPI langchain: < 0.0.247 → fixed in 0.0.247
Description
An issue in LangChain prior to v.0.0.247 allows a remote attacker to execute arbitrary code via the prompt parameter.
Related
Alias · CVE (1)
- CVE-2023-38860 An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter. vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-38860 advisory
- https://github.com/hwchase17/langchain/issues/7641 web
- https://github.com/langchain-ai/langchain/issues/7641 web
- https://github.com/langchain-ai/langchain/pull/8092 web
- https://github.com/langchain-ai/langchain/pull/8425 web
- https://github.com/langchain-ai/langchain/commit/d353d668e4b0514122a443cef91de7f76fea4245 web
- https://github.com/langchain-ai/langchain/commit/fab24457bcf8ede882abd11419769c92bc4e7751 web
- https://github.com/hwchase17/langchain package
- https://github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-145.yaml web