GitHub Advisoryadvisory · npm
GHSA-fjgf-rc76-4x9p Multer vulnerable to Denial of Service via unhandled exception from malformed request
HIGH
Official page ↗
- Aliases
- CVE-2025-7338
- Ecosystem
- npm
- Packages
- multer
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-248
- Reviewed
- 2025-07-17
Affected packages
• npm multer: >= 1.4.4-lts.1, < 2.0.2 → fixed in 2.0.2
Description
Impact
A vulnerability in Multer versions >= 1.4.4-lts.1, < 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed request. This request causes an unhandled exception, leading to a crash of the process.
Patches
Users should upgrade to `2.0.2`
Workarounds
None
Related
Alias · CVE (1)
- CVE-2025-7338 Multer is a node.js middleware for handling `multipart/form-data`. vulnerability
Weakness · CWE (1)
- CWE-248 Uncaught Exception weakness
References
- https://github.com/expressjs/multer/security/advisories/GHSA-fjgf-rc76-4x9p web
- https://nvd.nist.gov/vuln/detail/CVE-2025-7338 advisory
- https://github.com/expressjs/multer/commit/adfeaf669f0e7fe953eab191a762164a452d143b web
- https://cna.openjsf.org/security-advisories.html web
- https://github.com/expressjs/multer package