GitHub Advisoryadvisory · Maven
GHSA-fjpm-hf7c-xgc2 Stored XSS vulnerability in Jenkins Publish Over SSH Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2022-23110
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:publish-over-ssh
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-11-29
Affected packages
• Maven org.jenkins-ci.plugins:publish-over-ssh: < 1.23 → fixed in 1.23
Description
Jenkins Publish Over SSH Plugin 1.22 and earlier does not escape the SSH server name, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Overall/Administer permission.
Related
Alias · CVE (1)
- CVE-2022-23110 Jenkins Publish Over SSH Plugin 1.22 and earlier does not escape the SSH server name, resulting in a stored cross-site scripting (XSS)… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-23110 advisory
- https://github.com/jenkinsci/publish-over-ssh-plugin/commit/edf4e981684326d371200541d440d26b141b269e web
- https://github.com/jenkinsci/publish-over-ssh-plugin package
- https://github.com/jenkinsci/publish-over-ssh-plugin/releases/tag/publish-over-ssh-1.23 web
- https://www.jenkins.io/security/advisory/2022-01-12/#SECURITY-2287 web
- http://www.openwall.com/lists/oss-security/2022/01/12/6 web