GitHub Advisoryadvisory · Packagist
GHSA-fjqg-w8g6-hhq8 Dolibarr vulnerable to Improper Authentication and Improper Access Control
HIGH
Official page ↗
- Aliases
- CVE-2021-25956
- Ecosystem
- Packagist
- Packages
- dolibarr/dolibarr
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-284, CWE-287
- Reviewed
- 2021-08-26
Affected packages
• Packagist dolibarr/dolibarr: >= 3.3.beta1, < 14.0.0 → fixed in 14.0.0
Description
In `Dolibarr` application, v3.3.beta1_20121221 to v13.0.2 have `Modify` access for admin level users to change other user’s details but fails to validate already existing “Login” name, while renaming the user `Login`. This leads to complete account takeover of the victim user. This happens since the password gets overwritten for the victim user having a similar login name.
Related
Alias · CVE (1)
- CVE-2021-25956 In “Dolibarr” application, v3.3.beta1_20121221 to v13.0.2 have “Modify” access for admin level users to change other user’s details but… vulnerability