GitHub Advisoryadvisory · Packagist

GHSA-fmg6-246m-9g2v Auth0 laravel-auth0 SDK has Insufficient Entropy in Cookie Encryption

HIGH Published 2026-04-03 Modified 2026-04-03 Official page ↗
Ecosystem
Packagist
Packages
auth0/login
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
Weaknesses
CWE-331
Reviewed
2026-04-03

Affected packages

• Packagist auth0/login: >= 7.0.0, < 7.21.0 → fixed in 7.21.0

Description

Impact In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. Am I Affected? You are affected if you meet the following preconditions: • Applications using laravel-auth0 SDK, versions between 7.0.0 and 7.20.0 • Laravel-auth0 SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0. Resolution Upgrade Auth0/laravel-auth0 to version 7.21.0 or greater.

Related

Weakness · CWE (1)

  • CWE-331 Insufficient Entropy weakness

References