GitHub Advisoryadvisory · npm
GHSA-fmh4-wr37-44fp React Server Components are Vulnerable to RCE
CRITICAL
Official page ↗
- Ecosystem
- npm
- Packages
- @vitejs/plugin-rsc
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2025-12-03
Affected packages
• npm @vitejs/plugin-rsc: < 0.5.3 → fixed in 0.5.3
Description
Summary
`@vitejs/plugin-rsc` vendors `react-server-dom-webpack`, which contained an unauthenticated remote code execution vulnerability in versions prior to 19.0.1, 19.1.2, and 19.2.1. See details in React repository's advisory https://github.com/facebook/react/security/advisories/GHSA-fv66-9v8q-g76r
Impact
Applications using affected versions of `@vitejs/plugin-rsc` are vulnerable to unauthenticated remote code execution through deserialization of untrusted data. An attacker can execute arbitrary code remotely without authentication, affecting confidentiality, integrity, and availability.
Recommendations
Upgrade immediately to `@vitejs/[email protected]` or later.
Workarounds
Applications not using server-side React or React Server Components are unaffected.
Related
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://github.com/facebook/react/security/advisories/GHSA-fv66-9v8q-g76r web
- https://github.com/vercel/next.js/security/advisories/GHSA-9qr9-h5gf-34mp web
- https://github.com/vitejs/vite-plugin-react/security/advisories/GHSA-fmh4-wr37-44fp web
- https://github.com/vitejs/vite-plugin-react package
- https://react.dev/blog/2025/12/03/critical-security-vulnerability-in-react-server-components web