GitHub Advisoryadvisory · PyPI

GHSA-fmrf-6jv9-qjc7 LlamaIndex is vulnerable to Path Traversal attack through its ObsidianReader class

HIGH Published 2025-07-07 Modified 2025-07-07 Official page ↗
Aliases
CVE-2025-3046
Ecosystem
PyPI
Packages
llama-index-readers-obsidian
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-22
Reviewed
2025-07-07

Affected packages

• PyPI llama-index-readers-obsidian: < 0.5.1 → fixed in 0.5.1

Description

A vulnerability in the `ObsidianReader` class in LlamaIndex Readers Integration: Obsidian before version 0.5.1 from the run-llama/llama_index repository (versions 0.12.23 to 0.12.28) allows for arbitrary file read through symbolic links. The `ObsidianReader` fails to resolve symlinks to their real paths and does not validate whether the resolved paths lie within the intended directory. This flaw enables attackers to place symlinks pointing to files outside the vault directory, which are then processed as valid Markdown files, potentially exposing sensitive information.

Related

Alias · CVE (1)

  • CVE-2025-3046 A vulnerability in the `ObsidianReader` class of the run-llama/llama_index repository, versions 0.12.23 to 0.12.28, allows for arbitrary… vulnerability

Weakness · CWE (1)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References