GitHub Advisoryadvisory · Packagist

GHSA-fp4h-j22r-vwcv Moodle allows attackers to obtain sensitive course information

MEDIUM Published 2022-05-13 Modified 2024-01-25 Official page ↗
Aliases
CVE-2015-2270
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Reviewed
2024-01-25

Affected packages

• Packagist moodle/moodle: < 2.6.9 → fixed in 2.6.9 • Packagist moodle/moodle: >= 2.7.0, < 2.7.6 → fixed in 2.7.6 • Packagist moodle/moodle: >= 2.8.0, < 2.8.4 → fixed in 2.8.4

Description

lib/moodlelib.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4, when the theme uses the blocks-regions feature, establishes the course state at an incorrect point in the login-validation process, which allows remote attackers to obtain sensitive course information via unspecified vectors.

Related

Alias · CVE (1)

  • CVE-2015-2270 lib/moodlelib.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4, when the theme uses the… vulnerability

References