GitHub Advisoryadvisory · RubyGems

GHSA-fp4w-jxhp-m23p Dependency Confusion in Bundler

HIGH Published 2021-05-24 Modified 2021-08-31 Official page ↗
Aliases
CVE-2020-36327
Ecosystem
RubyGems
Packages
bundler
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Reviewed
2021-05-20

Affected packages

• RubyGems bundler: >= 1.16.0, < 2.2.10 → fixed in 2.2.10 • RubyGems bundler: >= 2.2.11, < 2.2.18 → fixed in 2.2.18

Description

Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.17 sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application.

Related

Alias · CVE (1)

  • CVE-2020-36327 Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.16 sometimes chooses a dependency source based on the highest gem version number, which… vulnerability

References