GitHub Advisoryadvisory · Packagist
GHSA-fp5j-j7j4-mcxc CraftCMS has an RCE vulnerability via relational conditionals in the control panel
HIGH
Official page ↗
- Aliases
- CVE-2026-31857
- Ecosystem
- Packagist
- Packages
- craftcms/cms
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
- Weaknesses
- CWE-94
- Reviewed
- 2026-03-11
Affected packages
• Packagist craftcms/cms: >= 5.0.0-RC1, < 5.9.9 → fixed in 5.9.9
• Packagist craftcms/cms: >= 4.0.0-beta.1, < 4.17.4 → fixed in 4.17.4
Description
A Remote Code Execution vulnerability exists in the Craft CMS 5 conditions system.
The `BaseElementSelectConditionRule::getElementIds()` method passes user-controlled string input
through `renderObjectTemplate()` -- an unsandboxed Twig rendering function with escaping disabled.
Any authenticated Control Panel user (including non-admin roles such as Author or Editor) can achieve full
RCE by sending a crafted condition rule via standard element listing endpoints.
This vulnerability requires no admin privileges, no special permissions beyond basic control panel access, and
bypasses all production hardening settings (allowAdminChanges: false, devMode: false,
enableTwigSandbox: true).
Users should update to the patched 5.99 release to mitigate the issue.
Related
Alias · CVE (1)
- CVE-2026-31857 Craft is a content management system (CMS). vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness