GitHub Advisoryadvisory · Go
GHSA-fpcr-4rr5-hpcp Mattermost Server vulnerable to user account takeover when Single Sign-On OAuth2 is used
HIGH
Official page ↗
- Aliases
- CVE-2017-18906
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-613
- Reviewed
- 2026-02-06
Affected packages
• Go github.com/mattermost/mattermost-server: < 3.9.2-0.20170714134023-b17fca0d5ee7 → fixed in 3.9.2-0.20170714134023-b17fca0d5ee7
• Go github.com/mattermost/mattermost-server: >= 3.10.0, < 3.10.2 → fixed in 3.10.2
Description
An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2, when Single Sign-On OAuth2 is used. An attacker could claim somebody else's account.
Related
Weakness · not in database (1)
Alias · CVE (1)
- CVE-2017-18906 An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2, when Single Sign-On OAuth2 is used. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-18906 advisory
- https://github.com/mattermost/mattermost/commit/259ad46f30d0fac2f7c5c14f3b76b2170f7e90c7 web
- https://github.com/mattermost/mattermost/commit/b17fca0d5ee7557e3df1cf1d1da8bd749859e35f web
- https://github.com/mattermost/mattermost/commit/fbc170733e86f09b46ba754dd03304733d2f482f web
- https://github.com/mattermost/mattermost package
- https://mattermost.com/security-updates web