GitHub Advisoryadvisory · PyPI
GHSA-fpfv-jqm9-f5jm Incorrect Comparison in NumPy
MEDIUM
Official page ↗
- Aliases
- CVE-2021-34141
- Ecosystem
- PyPI
- Packages
- numpy
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-697
- Reviewed
- 2022-06-21
Affected packages
• PyPI numpy: < 1.22 → fixed in 1.22
Description
Incomplete string comparison in the numpy.core component in NumPy1.9.x, which allows attackers to fail the APIs via constructing specific string objects.
Related
Alias · CVE (1)
- CVE-2021-34141 An incomplete string comparison in the numpy.core component in NumPy before 1.22.0 allows attackers to trigger slightly incorrect copying… vulnerability
Weakness · CWE (1)
- CWE-697 Incorrect Comparison weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-34141 advisory
- https://github.com/numpy/numpy/issues/18993 web
- https://github.com/numpy/numpy/issues/18993#issuecomment-1010735102 web
- https://github.com/advisories/GHSA-fpfv-jqm9-f5jm advisory
- https://github.com/numpy/numpy package
- https://github.com/pypa/advisory-database/tree/main/vulns/numpy/PYSEC-2021-855.yaml web
- https://www.oracle.com/security-alerts/cpujul2022.html web