GitHub Advisoryadvisory · Maven

GHSA-fph2-fwjq-prjf Users with Overall/Read access could enumerate credentials IDs in Jenkins Fortify on Demand Plugin

MEDIUM Published 2022-05-24 Modified 2022-12-28 Official page ↗
Aliases
CVE-2020-2202
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:fortify-on-demand-uploader
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-285, CWE-862
Reviewed
2022-12-28

Affected packages

• Maven org.jenkins-ci.plugins:fortify-on-demand-uploader: < 6.0.1 → fixed in 6.0.1

Description

Fortify on Demand Plugin provides a list of applicable credentials IDs to allow users configuring the plugin to select the one to use. This functionality does not correctly check permissions in Fortify on Demand Plugin 6.0.0 and earlier, allowing any user with Overall/Read permission to get a list of valid credentials IDs. Those can be used as part of an attack to capture the credentials using another vulnerability. An enumeration of credentials IDs in Fortify on Demand Plugin 6.0.1 now requires the appropriate permissions.

Related

Alias · CVE (1)

  • CVE-2020-2202 A missing permission check in Jenkins Fortify on Demand Plugin 6.0.0 and earlier in form-related methods allowed users with Overall/Read… vulnerability

Weakness · CWE (2)

  • CWE-285 Improper Authorization weakness
  • CWE-862 Missing Authorization weakness

References