GitHub Advisoryadvisory · Maven

GHSA-fpj8-gq4v-p354 Apache Tomcat - Client certificate verification bypass

MEDIUM Published 2026-02-17 Modified 2026-08-31 Official page ↗
Aliases
CVE-2025-66614
Ecosystem
Maven
Packages
org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat, org.apache.tomcat:tomcat-coyote
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-20, CWE-295
Reviewed
2026-02-19

Affected packages

• Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.0-M1, < 11.0.15 → fixed in 11.0.15 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.0-M1, < 10.1.50 → fixed in 10.1.50 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.0-M1, < 9.0.113 → fixed in 9.0.113 • Maven org.apache.tomcat:tomcat: >= 11.0.0-M1, < 11.0.15 → fixed in 11.0.15 • Maven org.apache.tomcat:tomcat: >= 10.1.0-M1, < 10.1.50 → fixed in 10.1.50 • Maven org.apache.tomcat:tomcat: >= 9.0.0-M1, < 9.0.113 → fixed in 9.0.113 • Maven org.apache.tomcat:tomcat-coyote: >= 11.0.0-M1, < 11.0.15 → fixed in 11.0.15 • Maven org.apache.tomcat:tomcat-coyote: >= 10.1.0-M1, < 10.1.50 → fixed in 10.1.50 • Maven org.apache.tomcat:tomcat-coyote: >= 9.0.0-M1, < 9.0.113 → fixed in 9.0.113 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 8.5.0, <= 8.5.100 (no fix yet) • Maven org.apache.tomcat:tomcat: >= 8.5.0, <= 8.5.100 (no fix yet) • Maven org.apache.tomcat:tomcat-coyote: >= 8.5.0, <= 8.5.100 (no fix yet)

Description

Improper Input Validation vulnerability. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0-M1 through 9.0.112. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Older EOL versions are not affected. Tomcat did not validate that the host name provided via the SNI extension was the same as the host name provided in the HTTP host header field. If Tomcat was configured with more than one virtual host and the TLS configuration for one of those hosts did not require client certificate authentication but another one did, it was possible for a client to bypass the client certificate authentication by sending different host names in the SNI extension and the HTTP host header field. The vulnerability only applies if client certificate authentication is only enforced at the Connector. It does not apply if client certificate authentication is enforced at the web application. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fix the issue.

Related

Alias · CVE (1)

  • CVE-2025-66614 Improper Input Validation vulnerability. vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-295 Improper Certificate Validation weakness

References