GitHub Advisoryadvisory · Packagist
GHSA-fppq-f2m6-xv5c Improper Authorization vulnerability in Magento and Adobe Commerce
CRITICAL
Official page ↗
- Aliases
- CVE-2025-24434
- Ecosystem
- Packagist
- Packages
- magento/community-edition, magento/project-community-edition
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-285, CWE-863
- Reviewed
- 2025-02-12
Affected packages
• Packagist magento/community-edition: >= 2.4.8-beta1, < 2.4.8-beta2 → fixed in 2.4.8-beta2
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p4 → fixed in 2.4.7-p4
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p9 → fixed in 2.4.6-p9
• Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p11 → fixed in 2.4.5-p11
• Packagist magento/community-edition: < 2.4.4-p12 → fixed in 2.4.4-p12
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
Description
Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by an Improper Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized access. Exploitation of this issue does not require user interaction. A successful attacker can abuse this to achieve session takeover, increasing the confidentiality and integrity impact as high.
Related
Alias · CVE (1)
- CVE-2025-24434 Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by an Incorrect Authorization… vulnerability