GitHub Advisoryadvisory · Maven

GHSA-fpqp-v323-44xv Cross-site scripting in Apache Ranger

MEDIUM Published 2019-08-16 Modified 2021-08-17 Official page ↗
Aliases
CVE-2019-12397
Ecosystem
Maven
Packages
org.apache.ranger:ranger
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2019-08-09

Affected packages

• Maven org.apache.ranger:ranger: >= 0.7.0, < 2.0.0 → fixed in 2.0.0

Description

Policy import functionality in Apache Ranger 0.7.0 to 1.2.0 is vulnerable to a cross-site scripting issue. Upgrade to 2.0.0 or later version of Apache Ranger with the fix.

Related

Alias · CVE (1)

  • CVE-2019-12397 Policy import functionality in Apache Ranger 0.7.0 to 1.2.0 is vulnerable to a cross-site scripting issue. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References