GitHub Advisoryadvisory · Packagist

GHSA-fpqv-x9hm-35j9 Cross-site Scripting vulnerability in Kitodo.Presentation

MEDIUM Published 2020-07-31 Modified 2024-06-03 Official page ↗
Aliases
CVE-2020-16095
Ecosystem
Packagist
Packages
kitodo/presentation
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-07-30

Affected packages

• Packagist kitodo/presentation: < 3.1.2 → fixed in 3.1.2

Description

Impact Kitodo.Presentation fails to properly encode URL parameters for output in HTML making it vulnerable to Cross Site Scripting (XSS). Only sites using the `ListView`, `Navigation` or `PageView` plugins are affected. It also includes jQuery 3.4.1 which is known to be vulnerable against Cross Site Scripting, although there is currently no known way to exploit this in Kitodo.Presentation. Patches An updated version of Kitodo.Presentation is available on GitHub, Packagist and in the TYPO3 Extension Repository. Users are advised to update as soon as possible. The issue was also fixed in release 2.3.1 of the 2.x branch, although it is generally not recommended to run this branch since it depends on an outdated TYPO3 version. References TYPO3 Security Advisory TYPO3-EXT-SA-2020-015 jQuery Security Advisory GHSA-gxr4-xjj5-5px2 Open Bug Bounty Report OBB-1219978 Contact If you have any questions or comments about this advisory: • Open an issue • Email us at [email protected]

Related

Alias · CVE (1)

  • CVE-2020-16095 The dlf (aka Kitodo.Presentation) extension before 3.1.2 for TYPO3 allows XSS. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References