GitHub Advisoryadvisory · PyPI

GHSA-fpxx-xv4c-gxqp Apache Airflow vulnerable to sensitive information exposure when expose-config is set to non-sensitive-only

MEDIUM Published 2023-10-14 Modified 2024-03-06 Official page ↗
Aliases
CVE-2023-45348
Ecosystem
PyPI
Packages
apache-airflow
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-200
Reviewed
2023-10-17

Affected packages

• PyPI apache-airflow: >= 2.7.0, < 2.7.2 → fixed in 2.7.2

Description

Apache Airflow, versions 2.7.0 and 2.7.1, is affected by a vulnerability that allows an authenticated user to retrieve sensitive configuration information when the `expose_config` option is set to `non-sensitive-only`. The `expose_config` option is `False` by default. It is recommended to upgrade to a version that is not affected.

Related

Alias · CVE (1)

  • CVE-2023-45348 Apache Airflow, versions 2.7.0 and 2.7.1, is affected by a vulnerability that allows an authenticated user to retrieve sensitive… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References