GitHub Advisoryadvisory · Maven
GHSA-fq2h-r2h9-pj8r Jenkins NS-ND Integration Performance Publisher Plugin vulnerable to Cross-site Scripting
HIGH
Official page ↗
- Aliases
- CVE-2022-41229
- Ecosystem
- Maven
- Packages
- io.jenkins.plugins:cavisson-ns-nd-integration
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2022-09-23
Affected packages
• Maven io.jenkins.plugins:cavisson-ns-nd-integration: < 4.8.0.147 → fixed in 4.8.0.147
Description
Jenkins NS-ND Integration Performance Publisher Plugin prior to version 4.8.0.147 does not escape configuration options of the Execute NetStorm/NetCloud Test build step, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Related
Alias · CVE (1)
- CVE-2022-41229 Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.134 and earlier does not escape configuration options of the Execute… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-41229 advisory
- https://github.com/jenkinsci/cavisson-ns-nd-integration-plugin/commit/d77c6c7a279da002178f8244f37093773dd6aee5 web
- https://github.com/jenkinsci/cavisson-ns-nd-integration-plugin package
- https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-2858 web