GitHub Advisoryadvisory · Maven
GHSA-fq52-6cjf-jw59 Reflected XSS vulnerability in Jenkins VncRecorder Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2020-2206
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:vncrecorder
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-12-29
Affected packages
• Maven org.jenkins-ci.plugins:vncrecorder: < 1.35 → fixed in 1.35
Description
VncRecorder Plugin 1.25 and earlier does not escape a parameter value in the `checkVncServ` form validation endpoint output.
This results in a reflected cross-site scripting (XSS) vulnerability.
VncRecorder Plugin 1.35 escapes the parameter value in the output.
Related
Alias · CVE (1)
- CVE-2020-2206 Jenkins VncRecorder Plugin 1.25 and earlier does not escape a parameter value in the checkVncServ form validation endpoint, resulting in a… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness