GitHub Advisoryadvisory · Maven
GHSA-fq9f-9wv9-rfmg Improper Certificate Validation in Jenkins
MEDIUM
Official page ↗
- Aliases
- CVE-2017-1000396
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-295
- Reviewed
- 2022-07-01
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: < 2.73.2 → fixed in 2.73.2
• Maven org.jenkins-ci.main:jenkins-core: >= 2.74, < 2.84 → fixed in 2.84
Description
Jenkins 2.73.1 and earlier, 2.83 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks. This library is widely used as a transitive dependency in Jenkins plugins. The fix for CVE-2012-6153 was backported to the version of commons-httpclient that is bundled in core and made available to plugins.
Related
Alias · CVE (1)
- CVE-2017-1000396 Jenkins 2.73.1 and earlier, 2.83 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that… vulnerability
Weakness · CWE (1)
- CWE-295 Improper Certificate Validation weakness